Page 1 of 1

Failure on special chars in name

Posted: Tue Jul 22, 2008 12:54 am
by Nekudotayim
Hi,

I was trying to find two friends: Khellendrøs and Cybërelf, both from Warsong-US, and the system doesn't seem to recognise their special chars in name.

Thanks for your attention!

Re: Failure on special chars in name

Posted: Tue Jul 22, 2008 9:58 am
by Alex
Fixed, thanks for report :)

Re: Failure on special chars in name

Posted: Tue Jul 22, 2008 11:15 am
by Smashing
Alex wrote:Fixed, thanks for report :)

I beg to differ ;)
I'm having difficulties with my character, both on my char page and on my guild page as well.
Replication data:
Character name: Úrsus
Guild name: Yggdrasill
Server: Drak'thul - EU

When searching for my character right after the update didn't find him. Old search worked though.
Now it "works"... Didn't at first, then it finds an Úrsus (which is a feral druid) and displays all the related stuff, then it shows an Ursus (not the lak of ' over the U) who is a dwarf warrior and not related to my guild in any way.
Last time I checked the page found Ursus, the warrior and placed him in my guild using my gear...

Not sure how he'll handle that, knowing how dwarfs are

Re: Failure on special chars in name

Posted: Tue Jul 22, 2008 12:12 pm
by Alex
ah lol, sorry, this was a strange case: I used some function to capitalize first letter of each char name, and it seems its bugging for "special characters". I'll fix it asap.
It should be working fine when character name is starting with regular English alphabet letter.

Re: Failure on special chars in name

Posted: Tue Jul 22, 2008 2:21 pm
by Alex
I'm gonna have to pay some closer attention to these special chars. It will be fixed in the next few days

Re: Failure on special chars in name

Posted: Sun Aug 03, 2008 7:07 pm
by elyasmechera
This is Elyàs from the Tanaris US server... I don't show up on here. I get that special chars can make real weird problems in the coding.

Re: Failure on special chars in name

Posted: Sun Aug 03, 2008 10:29 pm
by Raven
I'm still having a similar problem with Médea

Alex here has even linked the page to me but I can't access, still saying "character not found"

Re: Failure on special chars in name

Posted: Mon Aug 04, 2008 7:02 pm
by Nekudotayim
Alex wrote:Fixed, thanks for report :)
Great, both working perfectly now! tyvm! :grin:

Re: Failure on special chars in name

Posted: Tue Aug 05, 2008 2:05 am
by samourai
hi im having problems with my hunter named flécheux i can see it in character but not in guild i would like to be able to compare with the rest of my guild pls ^^ .Btw ive given wow heroes adress to a lot of people ;) good job :grin:

Re: Failure on special chars in name

Posted: Tue Aug 05, 2008 1:07 pm
by Mathieu
Hi,

I can't find my character: Tào on Dath'Remar. It's probably related to an accentuated character issue as well.

Thanks,
Mathieu.